How do you rate this laptop with Linux?
Excellent
0% (0)
Good
 
50% (1)
Fair
0% (0)
Poor
0% (0)
Unusable
 
50% (1)

HP-Compaq 515

Introduction

This is a compatibility guide to running Linux with the HP-Compaq 515 laptop.

This page is just for discussing using Linux on the HP-Compaq 515. For a general discussion about this laptop you can visit the HP-Compaq 515 page on LapWik.

Editing This Page

If you would like to edit this page please first view our Editing Guidelines.

Specifications

For full specifications see the HP-Compaq 515 specifications page.

NameHP-Compaq 515
ProcessorAMD Turion X2 Dual-Core Mobile Processor RM-74 (2.2 GHz, 1 MB L2 cache)
AMD Athlon 64 X2 Dual-Core Processor for Notebook PCs QL-64 (2.1 GHz, 1 MB L2 cache)
Screen14\“ (1366×768) Widescreen
RAMUp to 8GB
HDD160GB to 250GB
Optical DriveDVD+-RW
GraphicsATI Mobility Radeon HD 3200
Network10/100 Ethernet
Broadcom 802.11a/b/g/draft n
Broadcom 802.11b/g

Linux Compatibility

DeviceCompatibilityComments
ProcessorWorks
ScreenWorks
HDDWorks
Optical DriveWorks
GraphicsWorks
SoundWorksYou need kernel 2.6.31 or greater, such as what is found in Ubuntu 9.10 or Fedora 12, for sound to work properly.
EthernetWorks
WirelessWorks
USBWorks
Card ReaderWorks
ExpressCard SlotNot Tested
WebcamWorks

Notes

Make sure you run a Linux distribution which uses kernel version 2.6.31 or greater to ensure maximum compatibility. Ubuntu 9.10 or Fedora 12 are good choices.

Summary

The HP-Compaq 515 works very well with Ubuntu 9.10 and Fedora 12.


Discussion

danny, 2014/04/07 03:29

buenas noches amigos… tengo un problema con mi compaq 515, anteriormente tenia w7 en mi laptop y la formatee a Xp. y no me reconoce la tarjeta de red inalambrica, le descargue el driver de esa computadora en la pagina oficial, instalo driver y no me hace nada.. mi tarjeta de red en una broadcom 802.11. me pueden ayudar Gracias…

moira , 2013/03/23 00:52

tengo un probrema se desactivo el mouse de mi compaq 515

jaime, 2012/06/08 21:41

hola
Mi PC es una COMPAQ 515 y no tengo configurada la camara, como puedo hacer. en otras palabras no funciona.

vito pelone, 2012/09/24 18:38

q tal Jaime, tengo el mismo problema tuyo, como lo resolviste? gracias por la informacion.

Yaher Rey , 2012/06/05 16:16

Miren tengo un problema mi notebook tambien es un compaq 515, y ayer mi hermana se le paso a caer. y despues de eso el notebook le prendio normal y todo pero despues se le apago y al prenderlo el notebook pestañea y aparece una pantalla azul , mi notebook cuando lo compre traia un Cd hp, creo que era para las configuraciones y ya no lo tengo como puedo encontrar ese cd o hay alguna otra solucio, desde ya muchas gracias, saludos !

mario toledo, 2012/03/09 19:28

alguien sabe xq la compaq 515 no enciende y queda encendida la luz blanca pequeña donde entra la corriente tengo ese problema cada tanto alguna solucion posible o a q se debe ese problema yo la uso sin bateria xq no la tengo.

ignacio morales schopf, 2012/04/04 00:19

la luz blanca enciende cuando no se trabaja con batería, eso es normal, pero si no enciende es mejor llevarlo donde un técnico

jose pablo, 2011/11/24 02:30

hola a todos tengo una lap-top515 la deje encendida con batería por mucho tiempo cuando la fui a encender por cargador ya no enciende la revisaron toda y no dan con el problema dicen que es la batería pero ella deve funcionar con la corriente eléctrica totalmente muerta no da ni encendido solo cuando le conecto la corriente enciende una pequeña luz al costado donde va el toma si pudieran orientarme estaré agradecido

mario toledo, 2012/03/09 19:24

hola jose pablo te keria preguntar si solucionas tu problema xq yo tengo el mismo, no me enciende me hacia eso con frecuencia pero la desenchufaba a cada rato o le cambia de toma corriente asta q prendia ahora no me enciende para nada y me queda la luz blanca encendida yo la uso sin bateria xq no la tengo la compre sin bateria. tambien tengo 2 cargadores y con los 2 me hace los mismo desde ya muchas gracias

Miguel Torres, 2012/05/16 18:32

Hola Jose Pablo y Mario Toledo , a mi me pasa exactamente lo mismo que a uds.. tengo la COMPAQ 515 y no tengo batería.. y ahora cuando la conecto al toma corriente, se enciende el led de color blanco que esta al lado del conector.. y no enciende..! ..AHORA.. uds solucionaron su problema.. cual era.?, porfavor mi corre es tvmiguel@hotmail.com

jaime gomez, 2011/06/09 02:50

amigos tengo un problema con mi notebook compaq 515, sucede que hace poco le entro un virus en recycler y tuve formatearlo de nuevo, el problema que se me presento es uno que nunca antes me habia pasaso, al momento de cerrar sesion para apagar mi notebook se queda pegado donde dice cerrando sesion y no lo puedo apagar automaticamente solo lo puedo apagar manteniendo presionado el boton de encendido, alguien me podria ayudar u orientar al respecto, se agradeceria muchisimo. saludos amigos y ojala que me puedan ayudar

natalia, 2011/06/09 12:35

virus? con linux?
Esta pagina es para los que tienen software libre

claudio_elblusero, 2011/04/12 06:13

muchachos tengo una compaq 515 (AMD Athlon x64, 2gb RAM y ATI raedon HD 3200)… tuve muchos problemas con el ubuntu (por ejemplo con el ACPI)… y me pase a debian… mucho la verdad no se… que programas necesito para tenerla a full corriendo… ya esta instalado de un CDROM por lo que tiene solo lo escencial… gracias desde ya

Arhego, 2011/03/05 23:36

Casualmente encontré este tip en la red donde nos muestran como arreglar el “desgarre” de imagen en Linux http://120linux.com/amd-catalyst-11-2/ para leer más detalles en el post. En mi caso mejoró aun más en navegadores como iceweasel.

Resumen:

# aticonfig –set-pcs-u32=DDX,EnableTearFreeDesktop,1

Saludos

Arhego, 2011/03/05 06:04

Que tal, luego de algún tiempo de inactividad me puse a buscar nuevamente como hacer funcionar mi ATI y tarjeta inalámbrica en la compaq 515 con Debian 6.

Ahora lo he logrado.

Para la tajeta inalámbrica utilizo el mismo proceso que he venido manejando desde otras versiones descargando el driver de esta página http://www.broadcom.com/support/802.11/linux_sta.php Hay que estar muy atentos del README.txt (instalación detallada) ya que trae algunas especificaciones que debemos seguir cuidadosamente para poder cargar apropiadamente los módulos del kernel.

Para la ATI descargamos los drivers desde esta página http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx?type=2.4.1&product=2.4.1.3.36&lang=English una vez descargado, abrimos la consola de root.
le damos permiso de ejecución:
# chmod +x ati-driver-installer-11-2-x86.x86_64.run
y ejecutamos
# sh ati-driver-installer-11-2-x86.x86_64.run
Reiniciamos
# init 6

Nuestra tarjeta ya estará funcionando, la he probado con la nueva versión del superTux Kart.

Saludos

Armando

jenifer, 2011/03/01 02:59

Bueno Lo Que Pasa Esque Tengo Un Compaq 515
lA Cosa esque La Bateria Ya No Funciona Solo Funciona si
Lo Tengo Cargando Y Cuando Lo Cargo Qon La Bateria ! No Me sale Que se Esta Cargando Ademas Mi Cargador Ya No Funciona Y Me Tube que Comprar Otro Cragdor ?
Sera El Cargador ? Ayudenme Porfa !

 Saludos 
Arhego, 2011/02/18 05:03

Ahora empiezo con la nueva versión de Debian, me va todo bien, hasta ahora sólo he detectado la tarjeta inalámbrica como no funcional, ya les estaré contando.

Saludos

Lucia, 2011/09/13 07:10

Gracias por tu esfuerzo. este es un buen proyecto para que todos lo hacen. Voy a gastar más cuando tengo el pueblo……
Tim Viec Lam

Romina, 2011/02/12 18:02

Hoola nesesito urgente ayuda esqetengo un compaq 515 y el teclado esta desconfiigurado y yae buscado en artas paginas , y la unica solucionj fueapretar 'fn' cuando escriba y ayuda porfa


Gracias:D

Miguelinho_Peru, 2011/02/02 18:38

Buenos primea vez que escribo a este sitio nesecito ayuda con mi compaq 515 le acabo de instalar linux ubuntu 10.10 y la verdad es que no me quejo del sistema operativo , el problema es al cerrar la pantalla no se queda en hibernar ni en suspensiòn se apaga y ya trate casi de todo y no funciona como puedo configurar esto ayudenme porfavor se lo agradesco de antemano mi msn es Alain_Miguel23@hotmail.com

nicolas paredes, 2010/12/28 15:30

hola tengo un problema con mi notbook el mouse o touch no funciona dice que no esta intalado y nose ke hacer por favor ayudarme les agradeceria mi msn es miquitho.-@live.cl por fvor ayudarmeeeeeeeeeeeeeeeeeeeeee

Paulo, 2010/12/28 22:52

hola, soy nuevo pero veamos:
primero revisa si tienes instalado xserver-xorg-input-synaptics
aptitude search xserver-xorg-input-synaptics
si te lo muestra con una “i” al lado izquierdo está instalado, si no instálalo

segundo si realizaste alguna modificación a tu xorg.conf recuerda si metiste mano en la sección inputDevices creo que se llama (ahora no estoy en mi pc) si modificaste algo de ahí realiza como root un:
X -configure
lo que te crea un archivo en /root/xorg.confALGO no recuerdo bien el nombre entero y compara la sección inputDevices de este archivo con la misma sección de tu xorg.conf eso te puede ayudar un poco.

Saludos.

Francisco - , 2010/10/03 18:38

Hola, alguien ya pudo poner debian y que funcione el escalado de frecuencia decidme como pliss xD lindo dia ^_^.

Nicolas alias cabezabrc, 2010/09/27 13:12

Estimados encontre la solucion para Ubuntu 10.04 Lts.-
Al instalarlo hacerlo bootear con el grup como noacpi acpi=off
Una vez iniciado ir a Sistema - Administracion - Controladores de Hardware e instalar la placa Wifi + la placa de video.- Solucionado!!

El problema esta en el kernel contra la placa Wifi que posee nuestras notebooks pero una vez instalado los drivers correspondientes se soluciona todo tipo de problemas!!!

Suerte espero que les sirva!

MASH, 2010/09/10 15:26

Hola, tengo un problema con compaq 515, las teclas de función que activan el brillo no funcionan la compu biene con windows 7, ademas trae un disco que dice SLED y no se como o para sirve alguien me podia explicar… se los agradecere…

frank, 2010/09/26 21:32

tienes que descargar el programa sinaptycs para aser funcionar el teclado

kary, 2010/08/18 06:50

ayuda!!!! no se como configurarle el teclado a mi compac 515 no logro hacer que el arroba salga solo aplastando alt Q
ayuda!!!

Uriel, 2010/09/08 02:09

Buen Dia Kary
Bueno para empezar necesito saber que linux estas tratando de usar y lo que tratas de hacer se hace en la configuracion de teclado seguramente esta configurado en español de españa (@ sale con altgr + 2) si kieres que salga con Q lo que tienes que hacer es configurar tu teclado en español de latinoamerica
Tengo una compaq 515 con ubuntu 10.04
Este es mi correo por si tienes alguna duda
Mixtlepickt@hotmail.com
Saludos
Que tengas un excelente dia

Eduardo Diaz , 2010/08/08 14:46

Corre todo perfecto con Debian Squeeze y Slackware

Aunque falta probar lo de Express Card,
Pd. con Ubuntu 10.04 he tenido millones de problema, pero con estas distro .. 0% de problemas !!!

gerardo, 2010/08/04 02:57

hola que tal les comento me vendieron una lap-top compaq 515 y el que me la bendio me vio la cara por que la maquina al pareser esta bloqueada con bios me la vendio bien cara y yo soy nuevo en esto en fin yo ya no pienso invertirle mucho a esa lap alguien me puede ayudar para desbloquiarla o donde me pueden recomendar llevarla para que la reparen
saludos graciasCode Text

gerardo, 2010/08/04 02:50

Bold Text

ignacio, 2010/07/15 21:35

hola, tengo un problema: :-|

cuando prendo mi hp-compaq 515 con ubuntu 10.04 LTS la pantalla se pone negra y no prende, solo se ve negro, con el boton de encendido prendido, lo que hago es que al prenderse dice COMPAQ y luego sale como un guion _ parpadeando y luego otro mas, en el segundo, en el segundo apreto varias teclas (la que sean) y hay se prende y dice UBUNTU y carga, pero me aburri de eso y necesito un solucion ya que soy nuevo en ubnutu y me gusto mucho.

Ezequiel, 2010/09/02 18:57

tuve el mismo problema con una compaq 515, pude instalar ubuntu 10.04 con la versión Alternate, una vez iniciado menú de instalación, aprete F6 para opciones y tilde “ACPI=OFF”, luego de eso el proceso de instalación anda perfecto. suerte!

Armath, 2010/06/11 21:02

Para los que tengan problemas con ubuntu y wifi:
Los drivers que trae ubuntu por defecto hacen que se cuelgue. Para instalarlo y que funcione todo correctamente hacer lo siguiente:
1- Entrar a la BIOS y desactivar el wifi
2- Instalar ubuntu
3- Entrar a la BIOS y activar el wifi
4- En el GRUB apretar la 'e' con el cursor encima de ubuntu, en la penultima linea agregar al final “linux noacpi ACPI=OFF” y apretar ctrl+X
5- Ubuntu va a iniciar, entrar al administrador de hardware y alli instalar los drivers para la tarjeta Broadcom
6- Reiniciar

Nicolas, 2010/06/13 15:17

Estoy probando espero tener suerte !!!

doug, 2010/06/26 20:44

Esta opción me anduvo perfecto, sólo que tuve que poner “acpi=off noapic” (si le ponía “noacpi” se me colgaba…)

Gracias!

doug, 2010/06/26 20:45

Ah, y después de esto, hay que instalar el driver propietario, ya que Ubuntu nos ofrece dos drivers (el de la comunidad que no anda y el propietario).

Paulo, 2010/06/01 21:50

Hola, mira a mí me sirvió este link:

http://www.broadcom.com/support/802.11/linux_sta.php

de ahí sacas los driver para tu arquitectura y luego sigues las instrucciones de la misma página en el link del README.txt

O lo otro es que simplemente te metas en los controladores privativos de tu sistema y conectada por cable instales el que corresponde a la wifi

Si no haz instalado tu tarjeta de video también puedes hacerlo desde ahí, esas son como las alternativas más simples.

Saludos

francisco, 2010/05/07 04:04

Hola, yo probe igual con ubuntu 10.04 lo unico que te puedo decir es que con DVD si puedes instalarlo sin que cuelge, si se cuelga, solo inicia la bios y recetea los valores predeterminados de la primera pestaña y los de la ultima intenta de nuevo, esto me funciono, por que pasa esto aun no lo se pero ando en ello, si logras instalar no actualizes o se colgara de nuevo bye… tamos en contacto, por cierto agradecimentos a Arhego ya que unas cosas que publico, pude hacer que funcione al 100% fedora 11 thanks …

Nicolas, 2010/05/12 20:38

Estimados tengo el mismo inconveniente Instale UBUNTU 10.04 la instalacion corrio perfecta pero cuando quiero ejectarlo se cuelga…

Encontre una “solucion” pero es un parche en realidad es poner ACPI=OFF y arranca y anda como en un tubo…

Pero me gustaria saber si a alguien le paso y encontro una solucion al inconveniente este…

Girolamo, 2010/05/06 01:35

Hola tengo una notebook Compaq 515. quise correr Ubuntu 10.04 desde el CD pero en determinado momento se “cuelga”, “tilda”, “duerme” , como les parezca. Hay alguna incompatibilidad? Me conviene probar con alguna otra versión de Linux? Gracias

Natalia, 2010/06/02 12:43

YO esoy usando Ubuntu 10.04 y me funciona bárbaro. Las versiones anteriores tenian algunos problemas: ubuntu 9.04 sin audio y 9.10 sin wireless. Lo que si, yo tenía instalado el 9.10 y lo actualice. Podes pobar, si tenes windows quemar el ISO con la velocidad mas baja para que no haya errores.

Saludos

Adrian, 2010/07/01 18:29

TEngo el mismo problema, a veces cuando inicia, no me aparece el grub se tilda, se congela en la pantalla en negro no arranca. Luego de un rato “congelada” tengo que mantener apretado el boton de encendido para que se apague y luego encenderla nuevamente y por ahi arranca. Puse que bootee en modo textual y no hay caso, siempre bootea en forma grafica, y ni me aparece las opciones de grub, a alguien le paso lo mismo? Por si ayuda estoy usando los drivers libres de la placa de video, no los propietarios.
Saludos
Adrian Staffolani
astaffolani_en_gmail.com

natalia, 2010/03/06 22:47

Hola gente!!
Tengo instalado ubuntu 9.10 en mi compaq 515 y me encanta!! El único problemita que quiero resolver es que no me reconoce la placa de red wireless.
Alguien podría decirme que tengo que hacer para activarla (paso a paso si es posible)

saludos

Natalia, 2010/02/26 15:56

Hola a todos!!
Yo tengo instalado en mi compaq 515 ubuntu Karmic. Funciona todo muy bien salvo que no detecta mi placa de network. Funcionaba con ubuntu 8.04, cuando la actualice caputo. He intentado todo lo que aparece en los foros de ubuntu, pero nada. Alguien tiene solucion para mi problema?

PD:Por favor diganme que hacer, paso a paso, soy nuevita!

Uriel, 2010/02/22 17:47

Buenos dias!!!!!!
Tengo una laptop compaq 515 y anteriormente le habia instalado linux pero habia porblemas en la version ubuntu 8.04 no me detectaba la tarjeta wireles y cuando le instale el 9.01 no me detectaba la tarjeta de sonido ahora instale la version 9.1 karmic koala y me detecta el sonido pero aun sigue sin funcionar la tarjeta wireless alguien me podria dar una solucion a mi problema.
mixtlepickt@hotmail.com

sampath, 2010/01/06 17:59

people please talk english i need help regarding the installation of sound driver for ubuntu 9.04 on my compaq 515

Natalia, 2010/02/26 15:57

I solved this problem when I upgrade to ubuntu 9.10

Arhego, 2010/01/02 03:25

Regresando después de un tiempo, ya antes les comente mis andanzas con mi máquina instalando SLED 11 pues bueno, después lo deje porque se pasmaba, instale Ubuntu y me pasaba lo mismo especialmente cuando funcionaba con batería (disminuyó la tasa pero el problema seguía).

Ahora: le puse Debian 5 Lenny http://cdimage.debian.org/debian-cd/5.0.3/amd64/iso-dvd/ (pueden descargar sólo el primer disco que es de instalación)

Me va perfectamente la compaq 515, de verdad,
Me detecto la ATI ( con problemas que luego solucione. ver abajo)
El sonido va perfecto (aun asi ejecuté alsa config)
La wifi no la detectó, pero sólo hay que seguir el mismo procedimiento de instalación explicado anteriormente en éste mismo wiki usado en SLED 11 y después me funcionó muy bien.

Es más el soporte para mp3 y cd esta perfecto con Rhythmbox y el vlc lo instale sin problemas.

Pues para configurar la ATI, debemos tener los headers y el gcc y hacer:

cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak100
apt-get install fglrx-control fglrx-driver module-assistant
m-a a-i fglrx
modprobe -r radeon drm
echo fglrx » /etc/modules
aticonfig –initial

Visto en: http://forums.debian.net/viewtopic.php?f=5&t=45484

Saludos y Feliz año nuevo!!

octavio, 2010/01/01 17:46

tengo mi lap-top compaq 515, habia instalado la version 9.10 pero con problemas al momento de iniciar ubuntu por la tarjeta grafica se apaga el ventilador y no manda video rara vez arranca,pasa lo mismo con fedora 12, y con open suse ultima version, con la unica version que al momento me funcia es con Ubuntu 8.04.3 LTS (Hardy Heron. con el unico inconveniente que la tarjeta de red inalambrica nunca me conecta, alguien me puede ayudar a resolver este problema. Gracias.

Arhego, 2010/01/02 03:27

Intenta con Debian, a mi me va de lujo, arriba explico algunos detalles que tuve que hacer post instalación.

Saludos

Jose, 2009/10/11 19:40

I have Ubuntu 9.04 and it works great, the problem is, that it doesn make any sound, I can not play any musicm I watch only muted movies… I'm still working to fix it.

momon, 2009/10/30 05:45

do you have your problem fixed yet, coz i have the same problem too..
plese let me know if you had fixed the sound in ubuntu 9.04
my ubuntu can play music an movies after i donwload aotumaticlly the codecs when it connected to the net.
but it still doesnt have any sound yet..
thank u.

Francisco, 2009/08/29 04:29

Hola, quisiera tener contacto con ustedes amigos mios, compañeros de equipo ya que trabajar cada uno por su cuenta esta medio dificil, por lo tanto quisiera compartir ideas sobre esta maquina y pues llegar mas rapido, a la solucion optima les dejo mi correo danielinux@live.com.mx

francisco, 2009/08/29 04:23

Hola pues te informo que si, tienes sonido por defaul con la vercion de ubuntu la 8.04.3 amd64, pero te y les informo que, e detectado un problema grave, esto es basado en el control del CPU, depues colocare una respuesta mas detallada por lo pronto recomiendo que instalen Ubuntu 8.04.3 para !386. me despiedo y saludos a todos los linuxeros ^_^ .

white hack, 2009/09/10 02:01

francisco, por que no nos cuentas un poco más sobre el problema grave que descubriste??, me gustaría saber ya que la instalación de ubuntu no la estoy haciendo para mí, sino que para un familiar que no sabe mucho de computación.

además , así otros usuarios pueden saber sobre este problema.

gracias

mixtlepickt, 2009/08/27 07:53

Hola
soy nuevo usuario en ubuntu y tengo una compaq 515 quiero saber si la tarjeta de sonido funciona instalando Ubuntu 8.04.3 o tambien tengo que hacer el proceso aqui mencionado.
Gracias.
Buen dia…

white hat, 2009/08/26 04:05

El problema de sonido (tan común) que se registra al instalar Ubuntu 9.04 (justy jackalope) se soluciona instalando la versión más actual de ALSA.
El chipset de sonido Intel HDA SB no está soportado por OSS, y dá muchos problemas en ALSA. Una paseo por la solución :

- sudo aptitude install build-essential libncurses-dev gettext xmlto xmltoman linux-headers-`uname -r`
- descargar el source más actual desde www.alsa-proyect.org de alsa-driver alsa-lib alsa-utils
- descomprimir los paquetes de código,
- en la carpeta de alsa-driver:

 1.
    sudo ./configure –with-cards=hda-intel –with-kernel=/usr/src/linux-headers-`uname -r`
 2.
    make
 3.
    sudo make install


- en las otras dos carpeta (alsa-utils y alsa-lib):

 1.
    ./configure && make && sudo make install

luego de reiniciar, solo basta subir los volúmenes…

sólo agregar que además, antes de compilar alsa-utils, deben instalar xmlto; con el siguiente comando: sudo aptitude install xmlto

Arhego, 2009/08/24 05:29

Afortunadamente para todos los que tenemos una Broadcom BCM4312 y usamos alguna distribución GNU/Linux (probado en compaq 515 con SLED 11 -Suse Linux Enterprise Desktop 11-) existe el driver oficial para la tarjeta.

Al instalar SLED 11, tampoco me detecto la tarjeta de red inalámbrica, para activarla seguí los siguientes pasos:

1.- Bajar el driver, para esta lap fue el “64-bit driver”, desde: http://www.broadcom.com/support/802.11/linux_sta.php
también descargue el README.txt y el 2.6.29 kernel patch pero para el caso solo usé el README.txt.

2.- pasamos a la isntalación propiamente del driver:

mkdir hybrid_wl
cp hybrid-portsrc-x86_64-v5_10_91_9.tar.gz hybrid_wl
cd hybrid_wl
tar -xzf hybrid-portsrc-x86_64-v5_10_91_9.tar.gz

Nota: Debemos conocer el kernel que estamos usando (uname -r) SLED 11 trae el 2.6.27.19-5-default

Pasamos a la creación del archivo wl.ko

make -C /lib/modules/2.6.27.19-5-default/build M=`pwd` clean
make -C /lib/modules/2.6.27.19-5-default/build M=`pwd`

su (ponemos la contraseña)

Nota: desde la Instalación SLED 11 no trae ni el ndwrapper ni los modulos aca usados, asi que pasamos a hacer los pasos:

modprobe ieee80211_crypt_tkip
insmod wl.ko

cd /etc/modprobe.d/
gedit blacklist

Añadir al final:

blacklist b43
blacklist b43legacy
blacklist bcm43xx

Hacemos que se cargue el modulo al iniciar sistema:

cd hybrid_wl (depende donde lo tengas)
cp wl.ko /lib/modules/2.6.27.19-5-default/kernel/wireless
depmod -a
modprobe wl

Para finalizar apretar el boton del wireless para reiniciarlo


Informacion tomada del README.txt y principalmente del blog:

www.leprosys.info/2008/11/driver-oficiales-de-broadcom-para.html

Arhego, 2009/08/23 06:38

Habilitar sonido para SLED 11 -Suse Linux Enterprise Desktop 11-

No fueron exactamente los pasos de Elvio, sin embargo ahora mismo ya tengo sonido en mi compaq 515.

Nota: “alsaconf” según leí en un foro de espacioLinux ya lo traen la mayoría de las ditribuciones, ya había hecho las instalaciones de los paquetes así que no se decir exactamente si ya lo tenía SLED incluso antes de hacer todo tipo de instalación, prueben y comenten.

Antes de descargar todo paquete, intenten sólo pasar a la “parte final” de éste documento, si funciona se ahorran todas las descargas, de lo contrario a descargar.

Descargar las últimas versiones de
alsa-driver
alsa-lib
alsa-utils

http://www.alsa-project.org/main/index.php/Main_Page

En la terminal:

su
cd /usr/src/
mkdir alsa

vamos a la carpeta donde están los ficheros descargados
cd /home/user/Descargas/
cp alsa-* /usr/src/alsa

regresamos a /usr/src/alsa
bzip2 -d alsa-*
Extraemos C/U de los tar:
tar -xvf alsa-driver-1.0.20.tar
tar -xvf alsa-lib-1.0.20.tar
tar -xvf alsa-utils-1.0.20.tar

cd alsa-driver-1.0.20.tar
./configure
make
make install

cd .. (regresa a /usr/src/alsa)
cd alsa-lib-1.0.20/
./configure
make
make install

cd .. (regresa a /usr/src/alsa)
cd alsa-utils-1.0.20/
./configure
(me manda error de dependencia curses library, instalo libncurses, python-curses desde equipo → instalar software)
(no logro encontrar la libreria adecuada, busco otra opción, la leo en un foro de openSuse)

Parte Final
ejecuto:
alsaconf
selecciono HDA-Intel
reinicio el equipo,
agregar al panel el control de volumen
Para mi gusto suena muy bajito pero es de tomar en cuenta que la máquina solo tiene una bocina

Listo!!
Incluso funciona el atajo del teclado yea jeje

P.D. Ahora que le puse los drivers de ATI, la batería me va de maravilla, supongo tenía mucho que ver

Arhego, 2009/08/23 04:47

Fe de erratas.

Los pasos para la configuración del sonido no los dio Francisco.

los detalles los da Elvio.

Disculpas,

Saludos.

Arhego, 2009/08/23 04:45

Para la tarjeta Gráfica ATI Radeon HD 3200 en la compaq 515, funciona bien con el siguiente driver:

https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/64bit/ati-driver-installer-9-1-x86.x86_64.run

Probado en: SLED 11 -Suse Linux Enterprise Desktop 11-

  1. su
  2. chmod +x ati-driver-installer-9-1-x86.x86_64.run
  3. ./ati-driver-installer-9-1-x86.x86_64.run


Seguimos los pasos de instalación, finaliza y reiniciamos la computadora, (yo la reinicie, tal vez con sólo reiniciar el servidor X funcione)

Probaré los pasos para el sonido que recomienda Francisco.

Arhego, 2009/08/31 18:28

Reinstale el SLED 11 al momento de probar los pasos que aquí publiqué para la tarjeta gŕafica y terminarlos, simplemente me mandaba error, después de estar buscando la solución me di cuenta que al momento de la instalación no había agregado las librerías de desarrollo.

Volví a realizar la instalación; en ésta ocasión agregando dichas librerías y al instalar el controlador de ATI ahora si, sin problemas.


Tip: recuerden poner las librerías de desarrollo al momento de la instalción.

Elvio, 2009/08/22 04:41

The oh-so-common problem with the sound (or rather lack of it) upon installing Ubuntu Justy Jackalope in this laptop, can be solved by simply installing the latest version of the ALSA driver… OSS does not support the sound chipset, btw.

Follow this instructions if you are suffering this well known issue:

. Prepare a building environment:
sudo aptitude install build-essential libncurses-dev gettext xmlto xmltoman linux-headers-`uname -r`

. Download the latest versions of alsa-driver, alsa-lib and alsa-utils source bundles available at www.alsa-proyect.org, and decompress in some safe directory (I suggest “mkdir -p /usr/src/alsa”).

In the alsa-driver directory:
- sudo ./configure –with-cards=hda-intel –with-kernel=/usr/src/linux-headers-`uname -r`
- sudo make
- sudo make install

In the other two directories (alsa-utils and alsa-lib), run:
- ./configure && make && sudo make install

After a system reboot to refresh the modules your compaq 515 should have sound. If not, just remember that main sound channels are muted by default (not my case), in which case you can use alsamixer.

Elvio, 2009/08/22 04:29

El problema de sonido (tan común) que se registra al instalar Ubuntu 9.04 (justy jackalope) se soluciona instalando la versión más actual de ALSA.
El chipset de sonido Intel HDA SB no está soportado por OSS, y dá muchos problemas en ALSA. Una paseo por la solución :

- sudo aptitude install build-essential libncurses-dev gettext xmlto xmltoman linux-headers-`uname -r`
- descargar el source más actual desde www.alsa-proyect.org de alsa-driver alsa-lib alsa-utils
- descomprimir los paquetes de código,
- en la carpeta de alsa-driver:

  1. sudo ./configure –with-cards=hda-intel –with-kernel=/usr/src/linux-headers-`uname -r`
  2. make
  3. sudo make install

- en las otras dos carpeta (alsa-utils y alsa-lib):

  1. ./configure && make && sudo make install


luego de reiniciar, solo basta subir los volúmenes…

Arhego, 2009/08/22 02:10

Estoy en ésto de configurar mi máquina para el “SUSE Linux Enterprise Desktop 11” se supone que en la hoja de especificaciones, éste SO junto con uno llamado Red Flag, están certificados para la instalación en modelo de Compaq 515, ya terminada la instalación pues resulta que no me ha reconocido correctamente la pantalla, al momento de querer encender el servidor X se traba y se queda sólo para línea de comando.

Entré como root, ejecuté sax2-vesa, elegí otro monitor para Compaq pero aun así no encuentro la configuración correcta, ya prende al menos el servidor X (Elegí compaq v500), la Broadcom no funciona, segun con NDIS wrapper puede hacerse funcionar, aun tengo que comprobarlo, la camara integrada pues no logro encontrarla (la verdad no me preocupa como prioridad).

Anterior a este sistema intenté primero con:

Windows XP: ese se lo pusieron por la compra del equipo, le deje otra particion, no lo he usado pero cuando me lo mostraron, todo correcto, lei que hubo quien tuvo problemas con la instalación de xp en la compaq 515, hubo que cambiar de SATA a IDE el HD desde la BIOS.

Ubuntu 9.01: pues sin problemas mayores, a excepcion del sonido, totalmente nulo, ah y la energía en bateria se la lleva que la regalan casi casi. :P ah por cierto, no pude activar asi nuevecita de instalación los efectos gráficos.

Back Track 3: todo muy bien hasta que quise aplicar un pequeño test al wifi… no me reconoció la Broadcom jeje

Open Suse 11.1: no me reconoció el teclado de la propia lap en la instalación, ni el touch pad, consegui mouse USB, conectó sin problemas, no conseguí teclado USB, hay murio. (al menos hasta que consiga un teclado con conector USB)

SUSE Linux Enterprise Desktop 11: pues aparte de lo primero descrito, ahora me doy cuenta que el consumo de la bateria también va que vuela, es necesario estar registrado en SUSE para descargarlo, dice que los primeros seis meses son con actualizaciones gratuitas, si quieres más los pagas, de lo contrario solo dejas de recibirlas. Por cierto hay que tener un buen ancho de banda para descargarlo rápido o estar en el sitio constantemente para que no te cierre sesión y se interrumpa la descarga. Por cierto, tampoco tengo sonido

Proximos sistemas a probar:

Red Flag Linux: Ya estoy descargando el ISO
Fedora: pronto descargare el ISO
CentOS: tambien lo bajaré
Ubuntu 8-04.3: luego lo descargo

Ahh quisiera tener más ancho de banda.
Si me acuerdo regreso a comentar, también pueden visitar mi blog en donde seguramente lo comentaré: http://arhego.axotla.com.mx

Saludos

Francisco, 2009/08/15 01:36

hi hola

Bueno pasó a comentar que tengo una compaq 515 y soy usuario de GNU/LINUX.
Los datos son

HP-Compaq 515
AMD Athlon 64 X2 Dual-Core Processor for Notebook PCs QL-64 (2.1 GHz, 1 MB L2 cache)
RAM 2 GB
HDD 160 GB
DVD+-RW
ATI Mobility Radeon HD 3200
Broadcom 802.11a/b/g/draft n
Broadcom 802.11b/g

la primer distro que instale fue Debian 5.0 hasta la fecha batallando, pero instale otro distro, uno con un poco mas de opciones, Ubuntu 8.04.3 LTS (Hardy Heron) y por lógica 64-bit PC (AMD64) desktop CD y este funciono de maravilla, detecto todo, tarjeta grafica, tarjeta Wireless, la cámara integrada que tiene, aun que como ya era de esperar, el consumo de energía es fuerte y en eso es en lo que ando en estos momentos.

Supongo yo que es una buena opción ya que este modelo lo encuentras sin S.O. instalado lo cual te reduce el costo y pues funciona perfectamente con Ubuntu 8-04.3. Espero que les sirva mi experiencia y un placer comentar para la comunidad GNU/Linux. ^_^

Francisco, 2009/12/03 05:24

Hola amigos de la comunidad GNU/Linux. Escribo para informarles del error ya comentado anteriormente, este error es producido por todas las distribuciones derivadas de debían, ya que no se permite el escalado de frecuencia. ¿Qué es esto?
El escalado de frecuencia del CPU, es la regulación de la velocidad, por ejemplo: en mi caso tengo un Athlon X2 64, velocidad o frecuencia 2.10 GHz total, la cual con los drivers adecuados baja a 1.05 GHz o sube cuando es necesario. ¿Qué pasa si esta frecuencia no es regulada? La batería en mi caso, en vez de durar 3:00 horas, dura 55 minutos. Mi ventilador esta siempre al 100% en uso para bajar la temperatura producida por esa velocidad, y lo más preocupante es que baja el tiempo de vida de mi Netbook. Por si esto fuera poco, no puedo tener la netbook en las piernas porque me las quema (jajajaja), por el momento estoy con la distribución de fedora 11, que proviene de RED HAT la cual si permite el escaldo de frecuencia, y a mi parecer es más importante este driver que otro. Después me preocupare por la red inalámbrica y los efectos de Compiz Fusion . Habiendo dicho esto, me despido. Att. Francisco,

                      Suerte ^_^ Comunidad GNU/Linux. 
octavio, 2010/01/01 17:48

tengo mi lap-top compaq 515, habia instalado la version 9.10 pero con problemas al momento de iniciar ubuntu por la tarjeta grafica se apaga el ventilador y no manda video rara vez arranca,pasa lo mismo con fedora 12, y con open suse ultima version, con la unica version que al momento me funcia es con Ubuntu 8.04.3 LTS (Hardy Heron. con el unico inconveniente que la tarjeta de red inalambrica nunca me conecta, alguien me puede ayudar a resolver este problema

Enter your comment. Wiki syntax is allowed:
If you can't read the letters on the image, download this .wav file to get them read to you.
 
hp-compaq_515.txt · Last modified: 2012/06/09 07:46 by billg
Contact Us Sister Sites Privacy Policy Terms of Use
Copyright © 2006-2013 Linlap.com and other authors